Saturday, April 24, 2010

LACP-VLAN Debian/Ubuntu

Link Aggregation Control ProtocolFyuh akhirnya LACP jalan juga di server Debian. Ribet tidak sesimple OpenBSD/FreeBSD but yah paling tidak akhirnya jalan juga deh. LACP (802.3ad) running di server Debian Lenny main bareng cisco 3750. Konfiguras buat pengingat:

/etc/network/interfaces
auto bond0
iface bond0 inet static
address 10.0.0.249
netmask 255.255.255.0
slaves eth0 eth1
bond_mode 802.3ad
bond_miimon 100
bond_downdelay 200
bond_updelay 200

auto vlan16
iface vlan16 inet static
address 10.0.8.19
netmask 255.255.255.0
gateway 10.0.8.254
vlan-raw-device bond0

/etc/modules
bonding
8021q


/etc/modprobe.d/arch/x86_64
alias bond0 bonding
options bonding mode=4 miimon=100 downdelay=200 updelay=200

Sedangkan untuk konfigurasi disisi switch cisco.
interface Port-channel6
description "Development"
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/13
description "DEVELOPMENT"
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 6 mode active
spanning-tree portfast trunk
spanning-tree bpdufilter enable
spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/14
description "DEVELOPMENT"
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 6 mode active
spanning-tree portfast trunk
spanning-tree bpdufilter enable
spanning-tree link-type point-to-point
!

Yaks sudah up tinggal testing.. yuks

2 comments:

  1. Kalau di OpenBSD 4.5/4.6
    pf:/etc# cat hostname.em{0,1}
    up

    pf:/etc# cat /etc/hostname.trunk0
    trunkproto lacp trunkport em0 trunkport em1 10.0.0.248 netmask 255.255.255.0

    pf:/etc# cat hostname.vlan16
    inet 10.0.8.19 255.255.255.0NONE vlan 16 vlandev trunk0 description "VLAN 16"

    Native bisa jalan di OpenBSD, di debian/ubuntu butuh tambahan ifenslave-2.6 & vlan

    ReplyDelete
  2. [...] Ubuntu Comunity, LACP DEBIAN Share Posted in Linux, Networking « TELEPON GRATIS DENGAN VOIP RAKYAT DI ANDROID You [...]

    ReplyDelete