Friday, February 8, 2008

Dmesg OpenBSD 4.2-Current Fri Feb 8 16:29:37 WIT 2008

Great work for OpenBSD team.
# sysctl hw.sensors
hw.sensors.acpitz0.temp0=55.05 degC (zone temperature)
hw.sensors.acpitz1.temp0=58.05 degC (zone temperature)
hw.sensors.acpibat0.volt0=10.80 VDC (voltage)
hw.sensors.acpibat0.volt1=unknown (current voltage), UNKNOWN
hw.sensors.acpibat0.amphour0=4.22 Ah (last full capacity)
hw.sensors.acpibat0.amphour1=0.21 Ah (warning capacity)
hw.sensors.acpibat0.amphour2=0.15 Ah (low capacity)
hw.sensors.acpibat0.amphour3=unknown (remaining capacity), UNKNOWN
hw.sensors.acpibat0.raw0=unknown (battery unknown), UNKNOWN
hw.sensors.acpibat0.raw1=0 (rate)
hw.sensors.acpiac0.indicator0=Off (power supply)

Azalia still not work and also driver for Broadcom Wireless adapter (http://www.nazgul.ch/bwi/bwi-firmware-1.4.tgz).
bwi0 at pci1 dev 0 function 0 "Broadcom BCM4312" rev 0x02: could not map memory space


OpenBSD 4.2-current (BETHESDA) #7: Fri Feb 8 16:29:37 WIT 2008
krisna@bethesda.ciputra.ac.id:/home/archives/src/sys/arch/i386/compile/BETHESDA
cpu0: AMD Turion(tm) 64 X2 ("AuthenticAMD" 686-class, 512KB L2 cache) 1.81 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,CX16
real mem = 1038700544 (990MB)
avail mem = 996372480 (950MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 11/22/07, BIOS32 rev. 0 @ 0xfdbc5, SMBIOS rev. 2.4 @ 0xdc010 (27 entries)
bios0: vendor Hewlett-Packard version "F.39" date 11/22/2007
bios0: Hewlett-Packard Presario V3000 (GM187PA#UUF)
acpi0 at bios0: rev 3
acpi0: tables DSDT FACP SLIC MCFG HPET APIC BOOT SSDT
acpi0: wakeup devices LID0(S3) SLPB(S3) KBD0(S3) PS2M(S3) MCEB(S4) DVDB(S4) QPWB(S4) PICB(S4) VDOB(S4) LTVB(S4) MAC0(S5) P2P0(S5)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpi device at acpi0 from table DSDT not configured
acpi device at acpi0 from table FACP not configured
acpi device at acpi0 from table SLIC not configured
acpi device at acpi0 from table MCFG not configured
acpihpet0 at acpi0 table HPET: 25000000 Hz
acpi device at acpi0 from table APIC not configured
acpi device at acpi0 from table BOOT not configured
acpi device at acpi0 from table SSDT not configured
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 5 (P2P0)
acpiprt2 at acpi0: bus 255 (XVR0)
acpiprt3 at acpi0: bus 3 (XVR1)
acpiprt4 at acpi0: bus 1 (XVR2)
acpiec0 at acpi0
acpitz0 at acpi0: critical temperature 98 degC
acpitz1 at acpi0: critical temperature 120 degC
acpicpu0 at acpi0: PSS
acpibtn0 at acpi0: LID0
acpibtn1 at acpi0: SLPB
acpibtn2 at acpi0: PWRB
acpibat0 at acpi0: BAT0 model "Primary" type LION oem "Hewlett-Packard "
acpiac0 at acpi0: AC unit online
bios0: ROM list: 0xc0000/0xf200 0xcf800/0x1800 0xdc000/0x4000!
cpu0 at mainbus0
cpu0: PowerNow! K8 1809 MHz: speeds: 1800 1600 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
"NVIDIA C51 Host" rev 0xa2 at pci0 dev 0 function 0 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 1 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 2 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 3 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 4 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 5 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 6 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 7 not configured
ppb0 at pci0 dev 2 function 0 "NVIDIA C51 PCIE" rev 0xa1
pci1 at ppb0 bus 1
bwi0 at pci1 dev 0 function 0 "Broadcom BCM4312" rev 0x02: could not map memory space
ppb1 at pci0 dev 3 function 0 "NVIDIA C51 PCIE" rev 0xa1
pci2 at ppb1 bus 3
vga1 at pci0 dev 5 function 0 vendor "NVIDIA", unknown product 0x0244 rev 0xa2
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"NVIDIA MCP51 Host" rev 0xa2 at pci0 dev 9 function 0 not configured
pcib0 at pci0 dev 10 function 0 "NVIDIA MCP51 ISA" rev 0xa3
nviic0 at pci0 dev 10 function 1 "NVIDIA MCP51 SMBus" rev 0xa3
iic0 at nviic0
spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
spdmem1 at iic0 addr 0x51: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
iic1 at nviic0
"NVIDIA MCP51 PMU" rev 0xa3 at pci0 dev 10 function 3 not configured
ohci0 at pci0 dev 11 function 0 "NVIDIA MCP51 USB" rev 0xa3: irq 11, version 1.0, legacy support
ehci0 at pci0 dev 11 function 1 "NVIDIA MCP51 USB" rev 0xa3: irq 7
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "NVIDIA EHCI root hub" rev 2.00/1.00 addr 1
pciide0 at pci0 dev 13 function 0 "NVIDIA MCP51 IDE" rev 0xf1: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
pciide0: channel 0 disabled (no drives)
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
pciide1 at pci0 dev 14 function 0 "NVIDIA MCP51 SATA" rev 0xf1: DMA
pciide1: using irq 5 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0:
wd0: 16-sector PIO, LBA48, 152627MB, 312581808 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
ppb2 at pci0 dev 16 function 0 "NVIDIA MCP51 PCI-PCI" rev 0xa2
pci3 at ppb2 bus 5
"Ricoh 5C832 Firewire" rev 0x00 at pci3 dev 9 function 0 not configured
sdhc0 at pci3 dev 9 function 1 "Ricoh 5C822 SD/MMC" rev 0x19: irq 10
sdmmc0 at sdhc0
"Ricoh 5C843 MMC" rev 0x01 at pci3 dev 9 function 2 not configured
"Ricoh 5C592 Memory Stick" rev 0x0a at pci3 dev 9 function 3 not configured
"Ricoh 5C852 xD" rev 0x05 at pci3 dev 9 function 4 not configured
azalia0 at pci0 dev 16 function 1 "NVIDIA MCP51 HD Audio" rev 0xa2: irq 10
azalia0: codec[s]: Conexant/0x5045
audio0 at azalia0
nfe0 at pci0 dev 20 function 0 "NVIDIA MCP51 LAN" rev 0xa3: irq 11, address 00:16:d3:ae:60:67
eephy0 at nfe0 phy 1: Marvell 88E1118 Gigabit PHY, rev. 0
pchb0 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb1 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb2 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb3 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0:
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 "NVIDIA OHCI root hub" rev 1.00/1.00 addr 1
biomask edfd netmask edfd ttymask ffff
mtrr: Pentium Pro MTRR support
uhidev0 at uhub1 port 3 configuration 1 interface 0 "vendor 0x04f3 PS/2+USB Mouse" rev 1.10/22.90 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.
wsmouse1 at ums0 mux 0
ugen0 at uhub1 port 4 "Broadcom Corp HP Integrated Module" rev 2.00/1.00 addr 3
softraid0 at root
root on wd0a swap on wd0b dump on wd0b


Apply patch from brad at comstyle.com

OpenBSD 4.2-current (BETHESDA) #8: Fri Feb 8 19:06:24 WIT 2008
krisna@bethesda.ciputra.ac.id:/home/archives/src/sys/arch/i386/compile/BETHESDA
cpu0: AMD Turion(tm) 64 X2 ("AuthenticAMD" 686-class, 512KB L2 cache) 1.81 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,CX16
real mem = 1038700544 (990MB)
avail mem = 996372480 (950MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 11/22/07, BIOS32 rev. 0 @ 0xfdbc5, SMBIOS rev. 2.4 @ 0xdc010 (27 entries)
bios0: vendor Hewlett-Packard version "F.39" date 11/22/2007
bios0: Hewlett-Packard Presario V3000 (GM187PA#UUF)
acpi0 at bios0: rev 3
acpi0: tables DSDT FACP SLIC MCFG HPET APIC BOOT SSDT
acpi0: wakeup devices LID0(S3) SLPB(S3) KBD0(S3) PS2M(S3) MCEB(S4) DVDB(S4) QPWB(S4) PICB(S4) VDOB(S4) LTVB(S4) MAC0(S5) P2P0(S5)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpi device at acpi0 from table DSDT not configured
acpi device at acpi0 from table FACP not configured
acpi device at acpi0 from table SLIC not configured
acpi device at acpi0 from table MCFG not configured
acpihpet0 at acpi0 table HPET: 25000000 Hz
acpi device at acpi0 from table APIC not configured
acpi device at acpi0 from table BOOT not configured
acpi device at acpi0 from table SSDT not configured
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 5 (P2P0)
acpiprt2 at acpi0: bus 255 (XVR0)
acpiprt3 at acpi0: bus 3 (XVR1)
acpiprt4 at acpi0: bus 1 (XVR2)
acpiec0 at acpi0
acpitz0 at acpi0: critical temperature 98 degC
acpitz1 at acpi0: critical temperature 120 degC
acpicpu0 at acpi0: PSS
acpibtn0 at acpi0: LID0
acpibtn1 at acpi0: SLPB
acpibtn2 at acpi0: PWRB
acpibat0 at acpi0: BAT0 model "Primary" type LION oem "Hewlett-Packard "
acpiac0 at acpi0: AC unit offline
bios0: ROM list: 0xc0000/0xf200 0xcf800/0x1800 0xdc000/0x4000!
cpu0 at mainbus0
cpu0: PowerNow! K8 1809 MHz: speeds: 1800 1600 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
"NVIDIA C51 Host" rev 0xa2 at pci0 dev 0 function 0 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 1 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 2 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 3 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 4 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 5 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 6 not configured
"NVIDIA C51 Memory" rev 0xa2 at pci0 dev 0 function 7 not configured
ppb0 at pci0 dev 2 function 0 "NVIDIA C51 PCIE" rev 0xa1
pci1 at ppb0 bus 1
bwi0 at pci1 dev 0 function 0 "Broadcom BCM4312" rev 0x02: irq 11ppb1 at pci0 dev 3 function 0 "NVIDIA C51 PCIE" rev 0xa1
pci2 at ppb1 bus 3
vga1 at pci0 dev 5 function 0 vendor "NVIDIA", unknown product 0x0244 rev 0xa2
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"NVIDIA MCP51 Host" rev 0xa2 at pci0 dev 9 function 0 not configured
pcib0 at pci0 dev 10 function 0 "NVIDIA MCP51 ISA" rev 0xa3
nviic0 at pci0 dev 10 function 1 "NVIDIA MCP51 SMBus" rev 0xa3
iic0 at nviic0
spdmem0 at iic0 addr 0x50: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
spdmem1 at iic0 addr 0x51: 512MB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
iic1 at nviic0
"NVIDIA MCP51 PMU" rev 0xa3 at pci0 dev 10 function 3 not configured
ohci0 at pci0 dev 11 function 0 "NVIDIA MCP51 USB" rev 0xa3: irq 11, version 1.0, legacy support
ehci0 at pci0 dev 11 function 1 "NVIDIA MCP51 USB" rev 0xa3: irq 7
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "NVIDIA EHCI root hub" rev 2.00/1.00 addr 1
pciide0 at pci0 dev 13 function 0 "NVIDIA MCP51 IDE" rev 0xf1: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
pciide0: channel 0 disabled (no drives)
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
pciide1 at pci0 dev 14 function 0 "NVIDIA MCP51 SATA" rev 0xf1: DMA
pciide1: using irq 5 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0:
wd0: 16-sector PIO, LBA48, 152627MB, 312581808 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
ppb2 at pci0 dev 16 function 0 "NVIDIA MCP51 PCI-PCI" rev 0xa2
pci3 at ppb2 bus 5
"Ricoh 5C832 Firewire" rev 0x00 at pci3 dev 9 function 0 not configured
sdhc0 at pci3 dev 9 function 1 "Ricoh 5C822 SD/MMC" rev 0x19: irq 10
sdmmc0 at sdhc0
"Ricoh 5C843 MMC" rev 0x01 at pci3 dev 9 function 2 not configured
"Ricoh 5C592 Memory Stick" rev 0x0a at pci3 dev 9 function 3 not configured
"Ricoh 5C852 xD" rev 0x05 at pci3 dev 9 function 4 not configured
azalia0 at pci0 dev 16 function 1 "NVIDIA MCP51 HD Audio" rev 0xa2: irq 10
azalia0: codec[s]: Conexant/0x5045
audio0 at azalia0
nfe0 at pci0 dev 20 function 0 "NVIDIA MCP51 LAN" rev 0xa3: irq 11, address 00:16:d3:ae:60:67
eephy0 at nfe0 phy 1: Marvell 88E1118 Gigabit PHY, rev. 0
pchb0 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb1 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb2 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb3 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0:
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 "NVIDIA OHCI root hub" rev 1.00/1.00 addr 1
biomask edfd netmask edfd ttymask ffff
mtrr: Pentium Pro MTRR support
uhidev0 at uhub1 port 3 configuration 1 interface 0 "vendor 0x04f3 PS/2+USB Mouse" rev 1.10/22.90 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.
wsmouse1 at ums0 mux 0
ugen0 at uhub1 port 4 "Broadcom Corp HP Integrated Module" rev 2.00/1.00 addr 3
softraid0 at root
root on wd0a swap on wd0b dump on wd0b


Look like bwi0 work
bwi0 at pci1 dev 0 function 0 "Broadcom BCM4312" rev 0x02: irq 11ppb1 at pci0 dev 3 function 0 "NVIDIA C51 PCIE" rev 0xa1

2 comments:

  1. Apply patch from brad at comstyle.com


    Where you get that patch ?

    ReplyDelete
  2. Already Commit to OpenBSD-4.3.

    My Wireless devices still not work, you can look at bwi(4).

    HARDWARE
    The following cards are among those supported by the bwi driver:

    Card Chip Bus Standard
    Apple Airport Extreme BCM4306 PCI b/g
    Apple Airport Extreme BCM4318 PCI b/g
    ASUS WL-138g BCM4318 PCI b/g
    Buffalo WLI-CB-G54 BCM4306 CardBus b/g
    Compaq R4035 onboard BCM4306 PCI b/g
    HP nx6125 BCM4319 PCI b/g
    Linksys WPC54G Ver 3 BCM4318 CardBus b/g
    Linksys WPC54GS Ver 2 BCM4318 CardBus b/g
    TRENDnet TEW-401PCplus BCM4306 CardBus b/g
    US Robotics 5411 BCM4318 CardBus b/g
    --
    My wireless chipset BCM4312 still not supported yet.

    ReplyDelete